読者です 読者をやめる 読者になる 読者になる

下位バージョンで新機能の関数が使えるようになるPEARライブラリ PHP_Compat

file_put_contentsなどの新しいバージョンで実装された新機能の関数を下位バージョンで使えるようにするPEARライブラリ。
http://pear.php.net/manual/ja/package.php.php-compat.php

<?php
require_once 'PHP/Compat.php';
$components = PHP_Compat::loadVersion('4.3.0');

とか使えそうだった(過去形)。

php4系はもうサポート終わってるから、いまさら使うこともないでしょうけど。
もっと早く見つければよかったー


TODO:こーいうことが無いように、もう一度PEARライブラリをあさる